Top Mounts - Help

Discussion in 'Clio Trophy Discussion' started by BenG, May 12, 2009.

  1. BenG

    BenG ClioTrophy Moderator

    Messages:
    2,162
    Likes Received:
    405
    Joined:
    Feb 19, 2008
    Location:
    Cumbria
    Trophy No.:
    266/500
    I noticed my top mounts are not sitting right today. They were fine when I removed the Solid Top mounts a while back and since then I have had a camber adjustment, maybe this has caused it ? They are fully tightened !

    Note: They do not even touch the Turrent !!! :confused:hock:

    37fc3d52.jpg

    d1cc538a.jpg

    Any ideas...? :?

    Thanks.
     
  2. g40steve

    g40steve

    Messages:
    1,407
    Likes Received:
    0
    Joined:
    Jul 20, 2006
    Location:
    Loughborough but mainly on trackdays!
    Nowt wrong with that??

    Just settling down.
     
  3. BenG

    BenG ClioTrophy Moderator

    Messages:
    2,162
    Likes Received:
    405
    Joined:
    Feb 19, 2008
    Location:
    Cumbria
    Trophy No.:
    266/500
    They never used to be like that. they used to be on a funny angle but they always made contact with the turrent.
    How can this be normal, they dont even hold the strut in place.
     
  4. hoolio

    hoolio

    Messages:
    5,541
    Likes Received:
    248
    Joined:
    Jul 27, 2006
    Location:
    OXFORD
    Trophy No.:
    307/500
    Ben, I can't believe you didn't, but did you put them back together correctly?
     
  5. Gman

    Gman

    Messages:
    193
    Likes Received:
    0
    Joined:
    Aug 2, 2008
    To me that does look like you've put them back together wrong, from memory thats the only thin that can be causing this.
     
  6. BenG

    BenG ClioTrophy Moderator

    Messages:
    2,162
    Likes Received:
    405
    Joined:
    Feb 19, 2008
    Location:
    Cumbria
    Trophy No.:
    266/500
    :lol: I am very good at taking things apart but not so good at putting them back together... :roll:

    Spring
    Top hat
    Bearing (flat side first)
    Rubber top mount (bottom half)
    Spacer thing...
    Nut
    Then the damper is fitted and the top part of the rubber top mount is fitted.
     

    Attached Files:

  7. g40steve

    g40steve

    Messages:
    1,407
    Likes Received:
    0
    Joined:
    Jul 20, 2006
    Location:
    Loughborough but mainly on trackdays!
    As the rubber top mount with bearing compresses so the gap gets bigger.

    You have already said you have added more camber hence the angle :smiley:

    It's a crap design.
     
  8. BenG

    BenG ClioTrophy Moderator

    Messages:
    2,162
    Likes Received:
    405
    Joined:
    Feb 19, 2008
    Location:
    Cumbria
    Trophy No.:
    266/500
    Yeah but when the bottom half of the top mount compresses (i.e. when you let the car off the jack,) the top half should be tightened up, there isnt enough thread on the strut for this to happen. They used to be fine. Maybe I need new ones ??
     
  9. Gib#244

    Gib#244

    Messages:
    401
    Likes Received:
    0
    Joined:
    Jan 3, 2007
    Location:
    Cumbria
    Ah don't worry about it....my old 172 cup on coilovers used to sit like that, if you turn your steering (full lock) they will usually touch somewhere. If there is no knocking don't worry! :smile:
     
  10. BenG

    BenG ClioTrophy Moderator

    Messages:
    2,162
    Likes Received:
    405
    Joined:
    Feb 19, 2008
    Location:
    Cumbria
    Trophy No.:
    266/500
    Still handles like a dream ! 8)

    They used to sit fine, hence why I am a bit curious why there like that now. I probably just need new ones ?

    Gib - when do you want to go for our next run out in the Lakes? My Trophy is in the garage undergoing a 2 day cleaning process ready for summer !
     
  11. hoolio

    hoolio

    Messages:
    5,541
    Likes Received:
    248
    Joined:
    Jul 27, 2006
    Location:
    OXFORD
    Trophy No.:
    307/500
    Ok the only thing I can think of now is that the ring nut is no longer fully done up as the car is now compressing the spring and top mount is grounding on that or that your doughnut is knackered. The extra camber won't help also were wheels pointing forward?
     
  12. BenG

    BenG ClioTrophy Moderator

    Messages:
    2,162
    Likes Received:
    405
    Joined:
    Feb 19, 2008
    Location:
    Cumbria
    Trophy No.:
    266/500
    Normally I would just remove them and have a look, however, I have camber bolts fitted and removing them would result in the geometry having to be setup again.

    I seems as if the bottom half of the top mount is compressing too much resulting in the strut being pushed up an extra few mm which is why the top half will not tighten all the way to the turrent.
     
  13. BenG

    BenG ClioTrophy Moderator

    Messages:
    2,162
    Likes Received:
    405
    Joined:
    Feb 19, 2008
    Location:
    Cumbria
    Trophy No.:
    266/500
    Yes the wheels are pointing forward. the other side is the same but a mirrored image.
     
  14. hoolio

    hoolio

    Messages:
    5,541
    Likes Received:
    248
    Joined:
    Jul 27, 2006
    Location:
    OXFORD
    Trophy No.:
    307/500
    Well its unlikely that both nuts would have worked loose to stop the top topmount screwing down so the doughnut part has probably sagged.
     
  15. BenG

    BenG ClioTrophy Moderator

    Messages:
    2,162
    Likes Received:
    405
    Joined:
    Feb 19, 2008
    Location:
    Cumbria
    Trophy No.:
    266/500
    Great ! :roll:

    Looks like ill have to get them replaced as well as have the geometry setup again. I may as well fit MF springs while im at it then, makes sense. Im tempted to fit MF STM's too ?

    36K service is due very soon too. It may be a very expensive summer.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.