Minor electrical issue

Discussion in 'Clio Trophy Discussion' started by evilandy, Dec 21, 2018.

  1. evilandy

    evilandy

    Messages:
    13
    Likes Received:
    7
    Joined:
    Oct 5, 2018
    Hi all,

    My Trophy seems to have developed a minor electrical issue I was hoping I may get some advice on.

    When I use the indicators or brake pedal the fog light indicator glows dimly and sometimes the rear wiper comes on.

    Does anyone have any hints or tips on what might be wrong?

    Cheers,

    Andy
     
  2. hoolio

    hoolio

    Messages:
    5,553
    Likes Received:
    250
    Joined:
    Jul 27, 2006
    Location:
    OXFORD
    Trophy No.:
    307/500
    Check your rear light clusters, there is possibly a short there caused by water ingress.
     
    dablk likes this.
  3. MarcB

    MarcB

    Messages:
    1,204
    Likes Received:
    57
    Joined:
    Nov 26, 2010
    Location:
    Uk
    As hoolio says, There is an earth strap at the back of the rear drivers light cluster, There is also the larger one from the chassis to the gearbox.

    I would check both these and rub them down as it sounds like one has corroded and causing a bad earth
     
    dablk likes this.
  4. evilandy

    evilandy

    Messages:
    13
    Likes Received:
    7
    Joined:
    Oct 5, 2018
    Cheers guys. Car electrics is new to me but I’ll take a look and see what I find.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.