Fast road cams?...

Discussion in 'Mk1 Clio' started by mk1madness, Feb 10, 2012.

  1. mk1madness

    mk1madness

    Messages:
    2
    Likes Received:
    0
    Joined:
    Jan 30, 2012
    On 270 fastroadcams there's a 20min install run in period yet does not specify if you have to do so many miles below certain rev range after to bed it all in more does anyone know if after the 20mins install if car is fine an works can you just drive it at normally?...
     
  2. Will#I#Ams

    Will#I#Ams

    Messages:
    107
    Likes Received:
    0
    Joined:
    Nov 24, 2011
    give it death :wink: you should alternate the revs you drive it at for a couple k miles.
     
  3. moono16v

    moono16v

    Messages:
    214
    Likes Received:
    0
    Joined:
    Nov 23, 2009
    Location:
    Manchester
    Please post your views on them, would love to find out what there like.
     
  4. aucky

    aucky

    Messages:
    625
    Likes Received:
    4
    Joined:
    Feb 3, 2010
    Location:
    Chester
    Trophy No.:
    214/500
    I think most people don't even know you have to run them in at all so I doubt its an issue. Best asking somene who knows though (specialist/tuning co etc).
     
  5. Will#I#Ams

    Will#I#Ams

    Messages:
    107
    Likes Received:
    0
    Joined:
    Nov 24, 2011
    tbh i found the 260s a better fitment. iv had 260s, 270s and tried the 270 inlet, 260 ex. car felt better on the 260s. was quicker, but then i never really had it mapped for the 270s, but on std map the 260s were quicker, not as lumpy, not as thirsty. mapped for 260s it was an awesome all round motor. 270s and map for 260s was less grunt down low, and not much diff anywhere else through the rev range. mapped for them i dare say it would have felt better.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.